RootsMagic Genealogy Software: Family History Made Easy

RootsMagic UK Technical Support

If you're having problems with RootsMagic, our FAQs below should help you.

We also recommend making sure you have the latest patch installed, as this may solve any problems you are having.

RootsMagic 7 for Mac is the US version and is only available as a download directly from RootsMagic. You can find out more and download the 'RootsMagic for Mac 7' program from the RootsMagic US website here: http://www.rootsmagic.com/mac/

Print this solution

Yes. RootsMagic is able to import a file, as long as it is in one of the following formats:

  • RootsMagic 1-6
  • Family Origins (v4 and later)
  • Family Tree Maker (2006 and earlier)
  • Legacy
  • PAF (Personal Ancestral File)
  • The Master Genealogist
  • GEDCOM (Note: most family history programs are able to export your information in GEDCOM format, usually by going to File > Export)

Print this solution

This error can be caused by either a corrupt database or by another program which is locking the RootsMagic database (which stops RootsMagic from accessing it). There are two solutions you can try:

1. Try opening your database in RootsMagic on another computer. If it won't open, then the database could be corrupt - try restoring an earlier back-up file, as this should solve the problem.

2. Close any programs that are running in the background which may be accessing your database (this could be something that indexes or backups our files, or something which looks at files, such as a virus scanner).

Print this solution

Search for and delete the RootsMagicApp.xml or press CTRL+SHIFT+U and click \"Reset program settings\" and \"reset registration information\". When you restart RootsMagic you will have to enter your registration code again.

Print this solution

This is usually due to a permissions problem - you will need to tell RootsMagic to save your files somewhere other than the "ProgramData" folder.

1- Go to Tools > Program Options.
2- Choose 'Folders', then change the default folders to somewhere different than the ProgramData folder, usually 'My Documents'. (You could create a new folder in 'My Documents' called RootsMagic to save all the information, and then choose this folder as the default folder in RootsMagic.)

You can also try running the program as an administrator:
1- Click on Start - All Programs - Roots Magic 4/5/6.
2- Right-click on the program icon for Roots Magic 4 and choose "Run as Administrator".

Print this solution

FamilySearch changed the way 3rd Party Products such as RootsMagic login through the FT API. If you use RootsMagic to work with FamilySearch Family Tree, you must be using RootsMagic version 7.0.6.0 or later.

Please be aware that if you have any version of RootsMagic prior to 7.0.6.0 it will not login any more to FamilySearch Family Tree. You would need to update to version 7 to be able to log into FamilySearch through the program.

You can upgrade to version 7 via the website at: http://www.rootsmagic.co.uk/upgrade/

Print this solution

As the spouse is blank, they will appear as 'Unknown Spouse' in the Pedigree View and Family View. Therefore you would need to unlink the individual from this 'Unknown Spouse'.

1- First, make a back-up of your database.
2- Select the individual from the index on the left-hand side, and choose the 'Family' tab to go to the Family View. (Do not double-click to bring up the Edit Person window, as you cannot unlink spouses from this screen).
3- Make sure the individual is still selected, and click on the small button to the right of their name (this should either be a pink circle with an image of a woman, or a blue circle with an image of a man). Select 'Unknown Spouse'.
4- Right click on the individual, choose Unlink -> From Spouse. This should then unlink your individual from their 'Unknown Spouse', and the blank line in the Edit Person window should then disappear.

Print this solution

RootsMagic has a feature that automatically attempts to locate broken links to images.

1 - Click "Lists" - "Media gallery"
2 - Click "Tools" - "Fix broken media links"

Print this solution

1. Open RootsMagic 3

2. If your database is not already open, you need to open it:
- Go to File > Open
- Browse to where your database is saved in the new 'Open' window that appears
- Click on a database to select it, the name of the file will appear in the 'file name box
- Then click 'Open'

3. Once opened, you can create a backup of your database:
- Go to File > Backup
- Select the option for "Floppy disk, hard drive, USB drive, etc."
- A new window will appear, title "Name of backup file". Choose to save the file on your Desktop, by selecting 'Desktop' in the drop-down menu at the top of the window. The file name should be filled in automatically for you.
- Once you've selected Desktop, click the 'Save' button. You database will be saved to your Desktop.

4. You can now close RootsMagic, by going to File > Exit. You may be prompted to make a backup of your database - you can do another backup if you wish, or choose to skip the backup.

5. Now you need to copy the backup that you saved on your desktop to a USB memory stick, to transfer across to your new computer.
- Plug your USB memory stick into your computer
- Open your memory stick by going to My Computer, then double-clicking on the icon for your memory stick (this might be called F: or G:, but as each computer is different it may be under another name/letter).
- Right-click on your backup that you saved on your Desktop, and choose 'Copy'.
- Go back to the window you opened that shows the content of your memory stick. Right-click in a white space in the window, and choose 'Paste'.
- Once the backup has been copied to your memory stick, you can safely remove the memory stick from your computer.

6. On your new computer, you first need to extract the information from your RootsMagic 3 backup file.
- Plug your USB memory stick into your computer
- Open your memory stick by going to My Computer, then double-clicking on the icon for your memory stick (this might be called F: or G:, but as each computer is different it may be under another name/letter).
- Right-click on your backup on the memory stick, and choose 'Copy'.
- Go back to the Desktop of your computer. Right-click in an empty space and choose 'Paste'. Your backup should now be on your Desktop. You can safely remove the memory stick from your system now, as you no longer need this.
- Right-click on the backup on your Desktop, and choose 'Extract All'.
- Extract the files by following the extraction wizard on screen. It should save the files in another folder of the same name on your Desktop, except you will see that it doesn't have a grey zip on the image of the folder.

7. You can now import your database into RootsMagic 7.
- Open RootsMagic 7.
- Go to File > Import, or choose 'Import a file from a different program' from the 'Welcome to RootsMagic' window.
- A new window will appear, which says 'Import File from Another Program'.
- Make sure 'RootsMagic (version 1-3)' is selected, then click 'I know where the file is'.
- The 'Open' window will appear. Browse to your Desktop in this window (either from the drop-down menu at the top, or if you are using Windows Vista/7, from the list on the left-hand side)
- Double-click on the folder to see the files from your RootsMagic 3 backup
- Select the file that ends in .rmg, and click Open
- You will then get a window up, asking you to create a new RootsMagic file. (You need to set up a new RootsMagic version 7 database, so your information from version 3 can be imported into version 7).
- Choose a file name, and any other options you want for your database, then click 'OK'.
- Your information will now be imported into the program.

Print this solution

1 - Run RootsMagic 3
2 - Open the database you wish to transfer
3 - Click "File" - "Copy database"
4 - Select a destination for the copy. If you are using Vista this must be outside of the "Program files" folder. I suggest creating a new folder on your desktop or in your documents folder
5 - Enter a file name and click "Save"
6 - Close RM3
7 - Open RM4
8 - Click "File" - "Import"
9 - Make sure that "RootsMagic (version 1-3) is selected and then click "I know where the file is"
10 - Navigate to the location of the file you created in step 4
11 - Select the file and click "Open"
12 - In the "Create a new file" window choose a name for the database and click "OK"

Print this solution

We recommend transferring a backup file from your old computer to your new computer using a USB memory stick.

1 - Run RootsMagic 4/5/6
2 - Open the database you wish to transfer
3 - Click "File" - "Backup"
4 - Click the "Browse" button, navigate to your memory stick, then click "Select Folder"
5 - Click "Begin backup"
6 - Close RootsMagic 4/5/6
7 - Go to your new computer and open RootsMagic 7
8 - Click "File" - "Restore"
9 - Click the "Browse" button and navigate to your memory stick
10 - Select the backup file and click "Open"
11 - Click "Begin restoring backup" to restore the backup and open your database

Print this solution

1. Open RootsMagic 7 and go to File > Open.
2. Click "Search for files" to let RootsMagic search your computer for any RootsMagic databases.
3. Once you see the one you would like to open in the list, click on it to select it and then click "Open file".
4. You will be prompted to convert the file to the version 7 format - click "Continue with conversion" to convert and open your database.

Print this solution

You probably already have a set of parents attached to the child - you can add another set of parents, and then mark each set as either 'Adopted' or 'Birth' parents.

To add a second set of parents:
- Go to the 'Family' View and select the child from the list on the left-hand side. You should see her appear as a child, with one set of parents above.
- Right-click on the child, and choose Add > Parents
- When asked if you want to add another set of parents, click 'Yes'
- You can then add the father and mother (if they are already in your database, choose 'Select Existing Person', or if you need to enter them as a new individual choose 'Add New Person').

To change the relationship to each parent:
- Double-click on the child to open the 'Edit Person' screen. You will see that they have two sets of parents listed.
- Select the birth parents, and on the right-hand side of the screen change the 'Relationship to father' and 'Relationship to mother' boxes to 'Birth'.
- Select the adoptive parents, and on the right-hand side of the screen change the relationships to 'Adopted' (as in the previous step).

You can then add an adoption fact, and select the adoptive parents from the drop-down list on the right-hand side.

Print this solution

Installing RootsMagic to your memory stick:

1 - Insert memory stick
2 - Run "RootsMagic To-Go"
3 - Click "Install RootsMagic to Removable Disk (:)"
4 - Click "Install" and follow the on-screen prompts to install RootsMagic to your memory stick.
5 - Click "Transfer Data to Removable Disk (:)"
6 - Select your file/files to transfer and click "Transfer files"
7 - Remove Memory stick
8 - Click "Close"

Transferring your database to your memory stick:

1 - Insert memory stick
2 - Run "RootsMagic To-Go"
3 - Click "Transfer Data to Removable Disk (:)"
4 - Select your file/files to transfer (tick the box next to the database) and click "Transfer files"
5 - Remove Memory stick
6 - Click "Close"

Using RootsMagic and your data on a different PC:

1 - Insert memory stick in to new PC
2 - When the autorun menu appears click "Run RootsMagic 7 using the program provided on the device". If the autorun menu does not appear navigate to "Computer", double-click on your memory stick, open the 'RootsMagic-7' folder, and double-click on RootsMagic.exe (it should be listed as an 'Application', with the RootsMagic Logo)
3 - On the Welcome screen click "Unlock the Full Versions"
4 - Enter your name and RootsMagic 7 installation code
5 - Click "Unlock"
6 - Choose your registration option and click "Continue"
7 - Click "File" - "Open"
8 - Click "Open a file"
9 - Navigate to the "RootsMagic 7" - "Data" folder on the memory stick
10 - Select your file and click "Open"

You only need to perform steps 3-6 the first time you use RM from the memory stick.

Print this solution

You can view the "RootsMagic To-Go: Running RootsMagic on a Flash Drive" webinar at RootsMagic.com

Print this solution

Your main database in RootsMagic is an RMGC file (e.g. SmithFamily.rmgc), and any backups you make are RMGB files (e.g. SmithFamily.rmgb).

You can open an RMGC file in RootsMagic by going to File > Open, however you can't open RMGB files in the same way. This is because an RMGB file is a compressed version of your database and is therefore smaller than your RMGC files. To open a RMGB file, you need to go to File > Restore.

The RMGB files are designed to be used when you need to revert to an earlier copy of your database after making a mistake, or if you need to restore your database after losing your original. Because of this, when you restore a backup file, it will overwrite your existing database - therefore we suggest only restoring a back-up file if it's absolutely necessary, as when you restore the file you will lose any changes you've made since making that backup.

Print this solution

Press CTRL+Shift+U (at the same time) then click "Reset Registration Information" then restart RootsMagic.

Alternatively:
1 - Close RootsMagic
2 - If you have Windows Vista/7:
        a) Click on the windows "Start" button
        b) In the "Search" box at the bottom, enter: RootsMagicApp.xml
If you have Windows XP:
        a) Click on the windows "Start" button and select "Search"
        b) Select "Files or folders"
        c) Type the following in the search box: RootsMagicApp.xml
        d) Click on "More advanced options"
        e) Tick the boxes next to "Search system folders", "Search hidden files and folders" and "Search subfolders"
        f) Click "Search"
3 - When you see a result for RootsMagicApp.xml delete it
4 - Now start RootsMagic
5 - At the Welcome screen click "Unlock the full version"
6 - Enter your name in the top box and your installation code in the bottom box

Print this solution

Once you have opened your database in version 6, you cannot open it in version 4/5, as it will have been converted to a later version of RootsMagic.

When opening a database in version 6, you will be advised to create a back-up of your file first, and will be notified that the file will be converted for you. Therefore, you can restore the most recent back-up of your database (a back-up you created from Version 4/5) to restore your database in RootsMagic version 4/5.

To do this, open RootsMagic 4/5 and go to File -> Restore, then follow the on-screen prompts to get your database back.

If you do not have a recent back-up of your database, you can export a GEDCOM file from version 6 (File -> Export), and then import the GEDCOM file back into version 4/5 (File -> Import).

Print this solution

The registration key is also know as an "Install Code". If purchased on CD, your registration key should be on a white slip of paper that should say "Your RootsMagic Install Code is:" followed by a number. This should be a mix of numbers and letters, for example RM6-AA1A-22BB-3CC3.

If you purchased the software as a download from either RootsMagic.co.uk or GenealogySupplies.com, then you can find your registration key in your original confirmation email. If you can't find this, please contact us and we should be able to find your registration key in our database.

Still can't find your registration key?
If you registered the program with RootsMagic then they may have a record of your registration key. You can request your key from their website at: http://www.rootsmagic.com/recover-key/

Print this solution

You can import a Family Tree Maker file into RootsMagic by going to File > Import.

Unfortunately you won't be able to do a direct import of an FTM 2014.1 file. (MacKiev changed the encryption code and the file format so RootsMagic cannot recognise it as a Family Tree Maker file.)

To work around this you will need to export the FTM 2014.1 file to the FTM 2012 format:
- Go to File > Export
- Under Output format select "Family Tree Maker 2012" from the drop down list
- Choose any other options as required
- Click OK to complete the export

This export will create an Ancestry version FTM 2012 backup of your database. RootsMagic will now be able to see and import these files.

Print this solution

If the disc will not run automatically when put into your CD/DVD drive, you can run the setup manually from the disc.

1 - Put the disc into your CD drive
2 - Go to 'My Computer' or 'Computer'
3 - Right-click on your CD drive and choose 'Open'
4 - Double-click the 'fsCommand' folder
5 - Double-click 'RMUK.exe' to run the setup. Follow the instructions to install RootsMagic.

Print this solution

To get it back, delete the RMToolbar.ini file, which is located in:

XP: C:\Documents and Settings\YOUR USER NAME HERE\Application Data\RootsMagic\Version 4/5/6
Windows Vista/7/8: C:\users\YOUR USER NAME HERE\AppData\Roaming\RootsMagic\Version 4/5/6

Print this solution

As default, RootsMagic exports GEDCOM files in UTF-8 format. To change this to ANSI do the following:

1 - Right-click on the GEDCOM file and select "Open with" - "Notepad" (or "Wordpad")
2 - Change the line "2 VERS 5.5.1" to "2 VERS 5.5"
3 - Click "Save as" and change the "Encoding" option to "ANSI"
4 - Click "Save"

Print this solution

This is usually because your version 3 files are stored in the "Program Files" folder, and in Windows Vista & Windows 7, this is not allowed. So you would need to copy your database to somewhere outside the "Program Files" folder:

1. In RootsMagic 3, open your database
2. Click "File" > "Copy"
3. Choose a folder outside the Program Files folder (e.g. Documents)

You can now run RootsMagic 4/5/6 and import the copied version 3 database you have just saved.

Print this solution

This may be due to the setup of your PC. Try creating the shareable CD and then using your CD burning software to copy it to CD.

To do this, create the Shareable CD using RootsMagic, then stop when you reach the screen asking you whether you want to burn the CD now or later. You will see at the top of this screen a path where RootsMagic has saved the files for the Shareable CD. Make a note of this location, then choose 'I will burn it later'.

Go to the location where the files for the Shareable CD have been saved, then you can burn these files onto your CD using your own CD burning software, or using the Windows burn tool (copy the files onto the disc, choose 'Write these files to CD' to start burning).

Print this solution

You may find a few problems with RootsMagic and Windows 10. RootsMagic have released the following information via their blog:
"Apparently Microsoft snuck in a last-minute change that didn’t exist in earlier test versions and the upgrade has been a little bumpier than we had expected. There is a Windows registry entry needed in Windows 10 to allow programs to display data using the internal browser component (again, it was working in Windows 10 preview builds). This prevents the internal WebSearch from working, certain text appearing on some screens, and backing up to Dropbox and Google Drive."

To solve the problem, please follow the instructions below.

If you are running RootsMagic 7:
Make sure you have the latest patch. Go to Help > Check for Updates to make sure you are running the latest version.

If you are running RootsMagic 4, 5, or 6:
1. Click here to download the .REG file
2. Run the .REG file to add the necessary entries to your Windows registry. It will display several scary warnings. Just keep telling it that “yes”, you do want to make the change. This registry fix is only needed if you are running RootsMagic 4, 5, or 6 under Windows 10.

Print this solution


© 2005-17 S&N Genealogy Supplies, West Wing, Manor Farm, Chilmark, Salisbury SP3 5AF - Tel: 01722 716121
Genealogy Software - Archival Products - Census Records - Genealogy Books - Genealogy Resources